部署DataHub

1.安装python

yum install -y  wget gcc make zlib-devel openssl openssl-devel libffi-devel;
wget https://www.python.org/ftp/python/3.9.5/Python-3.9.5.tar.xz;
tar Jxvf Python-3.9.5.tar.xz;
cd Python-3.9.5;
./configure prefix=/usr/local/python3;
make && make install;
ln -fs /usr/local/python3/bin/python3 /usr/bin/python3;
ln -fs /usr/local/python3/bin/pip3 /usr/bin/pip3;

查看版本

python3 --version

2.安装DataHub CLI

python3 -m pip install --upgrade pip wheel setuptools
python3 -m pip uninstall datahub acryl-datahub || true
python3 -m pip install --upgrade acryl-datahub
datahub version

如果提示没有此datahub version命令,是因为没添加环境变量,也可以执行python3 -m datahub version这个命令查看版本
附:如出现以下告警
WARNING: The scripts pip, pip3 and pip3.9 are installed in '/usr/local/python3/bin' which is not on PATH.
添加环境变量

echo 'export PATH=/usr/local/python3/bin:$PATH' >>~/.bashrc;
source ~/.bashrc
THE END
分享
二维码
< <上一篇
下一篇>>
文章目录
关闭
目 录